Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on Mar 4, 2024 via pnpm

toastify-react-native 1.0.2

πŸŽ‰ toastify-react-native allows you to add notifications to your react-native app (ios, android) with ease. No more nonsense!
Package summary
Share
79
issues
10
critical severity
vulnerability
7
license
3
43
high severity
vulnerability
15
license
9
meta
19
11
moderate severity
vulnerability
11
15
low severity
vulnerability
4
license
11
18
licenses
522
MIT
42
ISC
13
Apache-2.0
38
other licenses
BSD-3-Clause
13
BSD-2-Clause
4
Unlicense
3
N/A
3
+ 11 more
Package created
15 May 2021
Version published
15 May 2021
Maintainers
1
Total deps
615
Direct deps
4
License
MIT

Issues

79

10 critical severity issues

critical
Recommendation: None
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 1.9.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.17.12 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 1.3.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 3.0.5 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 1.7.3 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 0.2.4 or later
via: react-native@0.49.5 & others
Recommendation: Check the package code and files for license information
via: react-native@0.49.5 & others
Recommendation: Check the package code and files for license information
via: react-native@0.49.5 & others
Recommendation: Check the package code and files for license information
via: react-native@0.49.5 & others
Collapse
Expand

43 high severity issues

high
Recommendation: Upgrade to version 6.0.4 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.0.0 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 0.6.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 3.3.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 0.5.2 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 1.4.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.6.9 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.17.11 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 5.1.2 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.6.7 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.17.19 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 6.2.4 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.1.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.17.21 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 1.0.2 or later
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Validate that the package complies with your license policy
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react@16.14.0 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
via: react-native@0.49.5 & others
Collapse
Expand

11 moderate severity issues

moderate
Recommendation: Upgrade to version 4.17.11 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 5.0.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 0.5.0 or later
via: react-native@0.49.5 & others
Recommendation: None
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.6.9 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.0.0 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.17.21 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.28.4 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.1.3 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 0.2.1 or later
via: react-native@0.49.5 & others
Recommendation: None
via: react-native@0.49.5 & others
Collapse
Expand

15 low severity issues

low
Recommendation: Upgrade to version 2.3.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 4.17.5 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.3.1 or later
via: react-native@0.49.5 & others
Recommendation: Upgrade to version 2.6.1 or later
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Recommendation: Read and validate the license terms
via: react-native@0.49.5 & others
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
522 Packages, Including:
absolute-path@0.0.0
accepts@1.2.13
accepts@1.3.8
ajv@6.12.6
align-text@0.1.4
ansi-colors@1.1.0
ansi-cyan@0.1.1
ansi-escapes@3.2.0
ansi-gray@0.1.1
ansi-red@0.1.1
ansi-regex@2.1.1
ansi-regex@3.0.1
ansi-styles@2.2.1
ansi-styles@3.2.1
ansi-wrap@0.1.0
ansi@0.3.1
arch@2.2.0
arr-diff@1.1.0
arr-diff@2.0.0
arr-diff@4.0.0
arr-flatten@1.1.0
arr-union@2.1.0
arr-union@3.1.0
array-filter@0.0.1
array-map@0.0.1
array-reduce@0.0.0
array-slice@0.2.3
array-unique@0.2.1
array-unique@0.3.2
art@0.10.3
asap@2.0.6
asn1@0.2.6
assert-plus@1.0.0
assign-symbols@1.0.0
async@0.2.10
async@2.6.4
asynckit@0.4.0
aws4@1.12.0
babel-code-frame@6.26.0
babel-core@6.26.3
babel-generator@6.26.1
babel-helper-builder-react-jsx@6.26.0
babel-helper-call-delegate@6.24.1
babel-helper-define-map@6.26.0
babel-helper-function-name@6.24.1
babel-helper-get-function-arity@6.24.1
babel-helper-hoist-variables@6.24.1
babel-helper-optimise-call-expression@6.24.1
babel-helper-regex@6.26.0
babel-helper-remap-async-to-generator@6.24.1

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
42 Packages, Including:
anymatch@2.0.0
are-we-there-yet@1.1.7
base64-url@1.2.1
capture-exit@1.2.0
cli-width@2.2.1
cliui@2.1.0
cliui@3.2.0
color-support@1.1.3
fs.realpath@1.0.0
gauge@1.2.7
get-caller-file@1.0.3
glob-parent@2.0.0
glob@7.2.3
graceful-fs@4.2.11
har-schema@2.0.0
has-unicode@2.0.1
hosted-git-info@2.8.9
inflight@1.0.6
inherits@2.0.4
isexe@2.0.0
json-stringify-safe@5.0.1
lru-cache@4.1.5
minimatch@3.1.2
mute-stream@0.0.7
npmlog@2.0.4
once@1.4.0
pseudomap@1.0.2
remove-trailing-separator@1.1.0
require-main-filename@1.0.1
rimraf@2.7.1
sax@1.1.6
semver@5.7.2
set-blocking@2.0.0
signal-exit@3.0.7
slide@1.1.6
which-module@1.0.0
which@1.3.1
wrappy@1.0.2
write-file-atomic@1.3.4
y18n@3.2.2
yallist@2.1.2
yargs-parser@4.2.1

Apache License 2.0

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
use-patent-claims
place-warranty
Cannot
hold-liable
use-trademark
Must
include-copyright
include-license
state-changes
include-notice
13 Packages, Including:
aws-sign2@0.7.0
bser@2.1.1
caseless@0.12.0
fb-watchman@2.0.2
forever-agent@0.6.1
oauth-sign@0.9.0
request@2.88.2
spdx-correct@3.2.0
tunnel-agent@0.6.0
validate-npm-package-license@3.0.4
walker@1.0.8
watch@0.18.0
xcode@0.9.3

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
13 Packages, Including:
babel-preset-react-native@2.1.0
bcrypt-pbkdf@1.0.2
fbjs@0.8.14
jest-docblock@20.1.0-echo.1
jest-haste-map@20.1.0-echo.1
makeerror@1.0.12
qs@4.0.0
qs@6.5.3
react-devtools-core@2.5.2
react-native@0.49.5
source-map@0.5.7
tmpl@1.0.5
tough-cookie@2.5.0

BSD 2-Clause "Simplified" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
hold-liable
Must
include-copyright
include-license
4 Packages, Including:
esutils@2.0.3
normalize-package-data@2.5.0
uglify-js@2.7.5
uri-js@4.4.1

The Unlicense

Public Domain
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
private-use
modify
Cannot
include-copyright
hold-liable
Must
3 Packages, Including:
big-integer@1.6.52
stream-buffers@2.2.0
tweetnacl@0.14.5

N/A

N/A
3 Packages, Including:
metro-bundler@0.13.0
ms@0.7.1
options@0.0.6

BSD

Invalid
Not OSI Approved
3 Packages, Including:
regenerator-transform@0.10.1
regjsparser@0.1.5
stream-counter@0.2.0

MIT/X11

Invalid
Not OSI Approved
2 Packages, Including:
optimist@0.6.1
wordwrap@0.0.2

Apache License, Version 2.0

Invalid
Not OSI Approved
2 Packages, Including:
rx-lite-aggregates@4.0.8
rx-lite@4.0.8

(MIT OR Apache-2.0)

Permissive
1 Packages, Including:
atob@2.1.2

(AFL-2.1 OR BSD-3-Clause)

Permissive
1 Packages, Including:
json-schema@0.4.0

Public Domain

Invalid
Not OSI Approved
1 Packages, Including:
jsonify@0.0.1

Do What The F*ck You Want To Public License

Permissive
Not OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
sublicense
distribute
modify
Cannot
Must
rename
1 Packages, Including:
left-pad@1.3.0

Creative Commons Attribution 3.0 Unported

Uncategorized
Not OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
Cannot
Must
1 Packages, Including:
spdx-exceptions@2.5.0

Creative Commons Zero v1.0 Universal

Public Domain
Not OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
Cannot
Must
1 Packages, Including:
spdx-license-ids@3.0.17

(MIT OR CC0-1.0)

Public Domain
1 Packages, Including:
type-fest@0.7.1

(LGPL-2.0 or MIT)

Permissive
1 Packages, Including:
xmldom@0.1.31
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

4
All Dependencies CSV
β“˜ This is a list of toastify-react-native 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
react-native-modal11.10.014.72 kBMIT
prod peer
10
43
11
15
react-native-responsive-fontsize0.5.14.93 kBMIT
prod peer
10
43
11
15
react-native0.49.59.2 MBBSD-3-Clause
prod peer
10
43
11
15
react16.14.059.16 kBMIT
prod peer
1

Visualizations