Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on Feb 16, 2024 via pnpm

timestreamdb 0.2.0

A Timeseries Database in Node.js backed by LevelDB.
Package summary
Share
8
issues
1
critical severity
license
1
3
high severity
vulnerability
2
license
1
3
moderate severity
vulnerability
3
1
low severity
license
1
4
licenses
62
MIT
2
ISC
1
N/A
1
BSD
Package created
25 Sep 2013
Version published
9 Nov 2015
Maintainers
1
Total deps
66
Direct deps
4
License
MIT

Issues

8

1 critical severity issue

critical
Recommendation: Check the package code and files for license information
via: level-version@0.4.0
Collapse
Expand

3 high severity issues

high
Recommendation: Upgrade to version 4.3.2 or later
via: level-version@0.4.0
Recommendation: None
via: timestream@0.1.1
Recommendation: Validate that the package complies with your license policy
via: level-version@0.4.0
Collapse
Expand

3 moderate severity issues

moderate
Recommendation: Upgrade to version 0.9.5 or later
via: level-version@0.4.0 & others
Recommendation: Upgrade to version 1.2.3 or later
via: level-version@0.4.0 & others
Recommendation: Upgrade to version 5.7.2 or later
via: level-version@0.4.0 & others
Collapse
Expand

1 low severity issue

low
Recommendation: Read and validate the license terms
via: level-version@0.4.0
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
62 Packages, Including:
abstract-leveldown@0.12.4
array-pivot@1.0.1
bl@0.8.2
bops@0.1.1
bytewise@0.7.1
clone@0.1.19
core-util-is@1.0.3
deferred-leveldown@0.2.0
errno@0.1.8
flatnest@0.2.2
floordate@2.0.0
isarray@0.0.1
isarray@1.0.0
isnumber@1.0.0
level-fix-range@2.0.0
level-gc@1.0.4
level-onion@0.0.1
level-version@0.4.0
levelup@0.18.6
levelup@0.19.1
loose-interval@1.0.1
object-keys@0.4.0
process-nextick-args@1.0.7
process-nextick-args@2.0.1
prr@0.0.0
prr@1.0.1
readable-stream@1.0.34
readable-stream@1.1.14
readable-stream@2.2.11
readable-stream@2.3.8
safe-buffer@5.0.1
safe-buffer@5.1.2
sosj@0.3.0
stats-lite@1.0.3
stream-joins@0.1.5
stream-spigot@3.0.6
stream-splice@1.0.9
string_decoder@0.10.31
string_decoder@1.0.3
string_decoder@1.1.1
terminus@1.0.12
through2-filter@1.3.1
through2-filter@2.0.0
through2-map@1.2.1
through2-map@1.4.0
through2-spy@1.1.1
through2@0.2.3
through2@0.4.2
through2@0.5.1
through2@0.6.5

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
2 Packages, Including:
inherits@2.0.4
semver@5.1.1

N/A

N/A
1 Packages, Including:
base64-js@0.0.2

BSD

Invalid
Not OSI Approved
1 Packages, Including:
semver@2.3.2
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

4
All Dependencies CSV
β“˜ This is a list of timestreamdb 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
level-version0.4.010.26 kBMIT
prod
1
2
3
1
levelup0.19.146.61 kBMIT
prod
3
through2-map1.4.03.26 kBMIT
prod
timestream0.1.16.38 kBMIT
prod
1

Visualizations