Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on Mar 6, 2024 via pnpm

gulp-replace-task 0.2.0

Replace text patterns with applause.
Package summary
Share
11
issues
1
critical severity
vulnerability
1
6
high severity
vulnerability
3
license
1
meta
2
2
moderate severity
vulnerability
2
2
low severity
vulnerability
1
license
1
5
licenses
64
MIT
2
ISC
2
BSD-3-Clause
2
other licenses
BSD
1
BSD-2-Clause
1
Package created
20 Mar 2014
Version published
1 May 2015
Maintainers
1
Total deps
70
Direct deps
3
License
UNKNOWN

Issues

11

1 critical severity issue

critical
Recommendation: Upgrade to version 4.17.12 or later
via: applause@0.4.0
Collapse
Expand

6 high severity issues

high
Recommendation: Upgrade to version 4.17.11 or later
via: applause@0.4.0
Recommendation: Upgrade to version 4.17.19 or later
via: applause@0.4.0
Recommendation: Upgrade to version 4.17.21 or later
via: applause@0.4.0
Recommendation: Validate that the package complies with your license policy
via: gulp-util@3.0.8
via: applause@0.4.0
via: gulp-util@3.0.8
Collapse
Expand

2 moderate severity issues

moderate
Recommendation: Upgrade to version 4.17.11 or later
via: applause@0.4.0
Recommendation: Upgrade to version 4.17.21 or later
via: applause@0.4.0
Collapse
Expand

2 low severity issues

low
Recommendation: Upgrade to version 4.17.5 or later
via: applause@0.4.0
Recommendation: Read and validate the license terms
via: gulp-util@3.0.8
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
64 Packages, Including:
ansi-gray@0.1.1
ansi-regex@2.1.1
ansi-styles@2.2.1
ansi-wrap@0.1.0
applause@0.4.0
argparse@1.0.10
array-differ@1.0.0
array-uniq@1.0.3
beeper@1.1.1
chalk@1.1.3
clone-stats@0.0.1
clone@1.0.4
coffee-script@1.12.7
core-util-is@1.0.3
dateformat@2.2.0
escape-string-regexp@1.0.5
fancy-log@1.3.3
glogg@1.0.2
gulp-replace-task@0.2.0
gulp-util@3.0.8
gulplog@1.0.0
has-ansi@2.0.0
has-gulplog@0.1.0
isarray@0.0.1
isarray@1.0.0
js-yaml@3.14.1
lodash._basecopy@3.0.1
lodash._basetostring@3.0.1
lodash._basevalues@3.0.0
lodash._getnative@3.9.1
lodash._isiterateecall@3.0.9
lodash._reescape@3.0.0
lodash._reevaluate@3.0.0
lodash._reinterpolate@3.0.0
lodash._root@3.0.1
lodash.escape@3.2.0
lodash.isarguments@3.1.0
lodash.isarray@3.0.4
lodash.keys@3.1.2
lodash.restparam@3.6.1
lodash.template@3.6.2
lodash.templatesettings@3.1.1
lodash@3.10.1
minimist@1.2.8
multipipe@0.1.2
object-assign@3.0.0
parse-node-version@1.0.1
process-nextick-args@2.0.1
readable-stream@1.0.34
readable-stream@1.1.14

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
2 Packages, Including:
color-support@1.1.3
inherits@2.0.4

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
2 Packages, Including:
cson-parser@1.3.5
sprintf-js@1.0.3

BSD

Invalid
Not OSI Approved
1 Packages, Including:
duplexer2@0.0.2

BSD 2-Clause "Simplified" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
hold-liable
Must
include-copyright
include-license
1 Packages, Including:
esprima@4.0.1
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

3
All Dependencies CSV
β“˜ This is a list of gulp-replace-task 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
applause0.4.06.65 kBMIT
prod
1
4
2
1
gulp-util3.0.85.36 kBMIT
prod
2
1
through20.6.54.28 kBMIT
prod

Visualizations