Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Generated on Feb 25, 2024 via pnpm

google-search-scraper 0.1.0

Google search scraper with captcha solving support
Package summary
Share
54
issues
17
critical severity
vulnerability
1
license
16
26
high severity
vulnerability
9
license
8
meta
9
3
moderate severity
vulnerability
3
8
low severity
license
8
7
licenses
17
MIT
16
N/A
5
BSD
7
other licenses
BSD-like
3
ISC
2
BSD-2-Clause
1
BSD-3-Clause
1
Package created
14 May 2014
Version published
20 Jun 2018
Maintainers
1
Total deps
45
Direct deps
2
License
MIT

Issues

54

17 critical severity issues

critical
Recommendation: Upgrade to version 1.12.1 or later
via: cheerio@0.13.1
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: cheerio@0.13.1
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: cheerio@0.13.1
Recommendation: Check the package code and files for license information
via: cheerio@0.13.1
Recommendation: Check the package code and files for license information
via: cheerio@0.13.1
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Recommendation: Check the package code and files for license information
via: request@2.33.0
Collapse
Expand

26 high severity issues

high
Recommendation: Upgrade to version 6.0.4 or later
via: request@2.33.0
Recommendation: Upgrade to version 1.0.0 or later
via: request@2.33.0
Recommendation: Upgrade to version 3.1.3 or later
via: request@2.33.0
Recommendation: Upgrade to version 1.0.0 or later
via: request@2.33.0
Recommendation: Upgrade to version 1.4.1 or later
via: request@2.33.0
Recommendation: Upgrade to version 4.2.1 or later
via: request@2.33.0
Recommendation: Upgrade to version 9.0.1 or later
via: request@2.33.0
Recommendation: None
via: request@2.33.0
Recommendation: Upgrade to version 6.2.4 or later
via: request@2.33.0
Recommendation: Validate that the package complies with your license policy
via: request@2.33.0
Recommendation: Validate that the package complies with your license policy
via: request@2.33.0
Recommendation: Validate that the package complies with your license policy
via: request@2.33.0
Recommendation: Validate that the package complies with your license policy
via: request@2.33.0
Recommendation: Validate that the package complies with your license policy
via: request@2.33.0
Recommendation: Validate that the package complies with your license policy
via: cheerio@0.13.1
Recommendation: Validate that the package complies with your license policy
via: cheerio@0.13.1
Recommendation: Validate that the package complies with your license policy
via: cheerio@0.13.1
via: cheerio@0.13.1
via: cheerio@0.13.1
via: request@2.33.0
via: request@2.33.0
via: request@2.33.0
via: request@2.33.0
via: request@2.33.0
via: request@2.33.0
via: request@2.33.0
Collapse
Expand

3 moderate severity issues

moderate
Recommendation: Upgrade to version 0.6.0 or later
via: request@2.33.0
Recommendation: None
via: request@2.33.0
Recommendation: Upgrade to version 2.68.0 or later
via: request@2.33.0
Collapse
Expand

8 low severity issues

low
Recommendation: Read and validate the license terms
via: request@2.33.0
Recommendation: Read and validate the license terms
via: request@2.33.0
Recommendation: Read and validate the license terms
via: request@2.33.0
Recommendation: Read and validate the license terms
via: request@2.33.0
Recommendation: Read and validate the license terms
via: request@2.33.0
Recommendation: Read and validate the license terms
via: cheerio@0.13.1
Recommendation: Read and validate the license terms
via: cheerio@0.13.1
Recommendation: Read and validate the license terms
via: cheerio@0.13.1
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
17 Packages, Including:
async@0.9.2
core-util-is@1.0.3
form-data@0.1.4
google-search-scraper@0.1.0
htmlparser2@3.4.0
http-signature@0.10.1
isarray@0.0.1
node-uuid@1.4.8
psl@1.9.0
punycode@2.3.1
querystringify@2.2.0
readable-stream@1.1.14
requires-port@1.0.0
string_decoder@0.10.31
underscore@1.5.2
universalify@0.2.0
url-parse@1.5.10

N/A

N/A
16 Packages, Including:
asn1@0.1.11
assert-plus@0.1.5
aws-sign2@0.5.0
cheerio@0.13.1
combined-stream@0.0.7
ctype@0.5.3
delayed-stream@0.0.5
domhandler@2.2.1
domutils@1.3.0
domutils@1.4.3
forever-agent@0.5.2
mime@1.2.11
oauth-sign@0.3.0
qs@0.6.6
request@2.33.0
tunnel-agent@0.3.0

BSD

Invalid
Not OSI Approved
5 Packages, Including:
boom@0.4.2
cryptiles@0.2.2
hawk@1.0.0
hoek@0.9.1
sntp@0.2.4

BSD-like

Invalid
Not OSI Approved
3 Packages, Including:
CSSselect@0.4.1
CSSwhat@0.4.7
entities@0.5.0

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
2 Packages, Including:
inherits@2.0.4
json-stringify-safe@5.0.1

BSD 2-Clause "Simplified" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
hold-liable
Must
include-copyright
include-license
1 Packages, Including:
domelementtype@1.3.1

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
1 Packages, Including:
tough-cookie@4.1.3
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

2
All Dependencies CSV
β“˜ This is a list of google-search-scraper 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
cheerio0.13.1120.78 kBUNKNOWN
prod
5
5
3
request2.33.020.21 kBUNKNOWN
prod
12
21
3
5

Visualizations