Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on Mar 7, 2024 via pnpm

expo-splash-screen 0.21.1

Provides a module to allow keeping the native Splash Screen visible until you choose to hide it.
Package summary
Share
30
issues
2
critical severity
license
2
6
high severity
license
5
meta
1
18
moderate severity
vulnerability
1
license
9
meta
8
4
low severity
license
4
16
licenses
539
MIT
63
ISC
11
BSD-3-Clause
46
other licenses
BSD-2-Clause
10
Apache-2.0
9
MPL-2.0
9
(MIT OR CC0-1.0)
4
+ 9 more
Package created
31 Mar 2020
Version published
2 Aug 2023
Maintainers
26
Total deps
659
Direct deps
2
License
MIT

Issues

30

2 critical severity issues

critical
Recommendation: Check the package code and files for license information
via: expo@50.0.11
Recommendation: Check the package code and files for license information
via: expo@50.0.11
Collapse
Expand

6 high severity issues

high
Recommendation: Read and validate the license terms
via: @expo/prebuild-config@6.3.0
Recommendation: Read and validate the license terms
via: @expo/prebuild-config@6.3.0
Recommendation: Read and validate the license terms
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the license expression complies with your license policy
via: expo@50.0.11
via: expo@50.0.11
Collapse
Expand

18 moderate severity issues

moderate
Recommendation: Upgrade to version 7.5.2 or later
via: @expo/prebuild-config@6.3.0 & others
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
Recommendation: Validate that the package complies with your license policy
via: expo@50.0.11
via: @expo/prebuild-config@6.3.0 & others
via: expo@50.0.11
via: expo@50.0.11
via: expo@50.0.11
via: expo@50.0.11
via: expo@50.0.11
via: expo@50.0.11
via: expo@50.0.11
Collapse
Expand

4 low severity issues

low
Recommendation: Read and validate the license terms
via: @expo/prebuild-config@6.3.0
Recommendation: Read and validate the license terms
via: @expo/prebuild-config@6.3.0
Recommendation: Read and validate the license terms
via: expo@50.0.11
Recommendation: Read and validate the license terms
via: expo@50.0.11
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
539 Packages, Including:
@babel/code-frame@7.10.4
@babel/code-frame@7.23.5
@babel/compat-data@7.23.5
@babel/core@7.24.0
@babel/generator@7.23.6
@babel/helper-annotate-as-pure@7.22.5
@babel/helper-builder-binary-assignment-operator-visitor@7.22.15
@babel/helper-compilation-targets@7.23.6
@babel/helper-create-class-features-plugin@7.24.0
@babel/helper-create-regexp-features-plugin@7.22.15
@babel/helper-define-polyfill-provider@0.5.0
@babel/helper-environment-visitor@7.22.20
@babel/helper-function-name@7.23.0
@babel/helper-hoist-variables@7.22.5
@babel/helper-member-expression-to-functions@7.23.0
@babel/helper-module-imports@7.22.15
@babel/helper-module-transforms@7.23.3
@babel/helper-optimise-call-expression@7.22.5
@babel/helper-plugin-utils@7.24.0
@babel/helper-remap-async-to-generator@7.22.20
@babel/helper-replace-supers@7.22.20
@babel/helper-simple-access@7.22.5
@babel/helper-skip-transparent-expression-wrappers@7.22.5
@babel/helper-split-export-declaration@7.22.6
@babel/helper-string-parser@7.23.4
@babel/helper-validator-identifier@7.22.20
@babel/helper-validator-option@7.23.5
@babel/helper-wrap-function@7.22.20
@babel/helpers@7.24.0
@babel/highlight@7.23.4
@babel/parser@7.24.0
@babel/plugin-bugfix-safari-id-destructuring-collision-in-function-expression@7.23.3
@babel/plugin-bugfix-v8-spread-parameters-in-optional-chaining@7.23.3
@babel/plugin-bugfix-v8-static-class-fields-redefine-readonly@7.23.7
@babel/plugin-proposal-async-generator-functions@7.20.7
@babel/plugin-proposal-class-properties@7.18.6
@babel/plugin-proposal-decorators@7.24.0
@babel/plugin-proposal-export-default-from@7.23.3
@babel/plugin-proposal-nullish-coalescing-operator@7.18.6
@babel/plugin-proposal-numeric-separator@7.18.6
@babel/plugin-proposal-object-rest-spread@7.20.7
@babel/plugin-proposal-optional-catch-binding@7.18.6
@babel/plugin-proposal-optional-chaining@7.21.0
@babel/plugin-proposal-private-property-in-object@7.21.0-placeholder-for-preset-env.2
@babel/plugin-syntax-async-generators@7.8.4
@babel/plugin-syntax-class-properties@7.12.13
@babel/plugin-syntax-class-static-block@7.14.5
@babel/plugin-syntax-decorators@7.24.0
@babel/plugin-syntax-dynamic-import@7.8.3
@babel/plugin-syntax-export-default-from@7.23.3

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
63 Packages, Including:
@isaacs/cliui@8.0.2
@isaacs/ttlcache@1.4.1
@npmcli/fs@1.1.1
at-least-node@1.0.0
cacache@15.3.0
chownr@2.0.0
electron-to-chromium@1.4.695
fastq@1.17.1
foreground-child@3.1.1
fs-minipass@2.1.0
fs.realpath@1.0.0
glob-parent@5.1.2
glob@10.3.10
glob@6.0.4
glob@7.1.6
glob@7.2.3
graceful-fs@4.2.11
hosted-git-info@3.0.8
infer-owner@1.0.4
inflight@1.0.6
inherits@2.0.4
ini@1.3.8
isexe@2.0.0
lru-cache@10.2.0
lru-cache@5.1.1
lru-cache@6.0.0
minimatch@3.1.2
minimatch@9.0.3
minipass-collect@1.0.2
minipass-flush@1.0.5
minipass-pipeline@1.2.4
minipass@3.3.6
minipass@5.0.0
minipass@7.0.4
npm-package-arg@7.0.0
once@1.4.0
osenv@0.1.5
picocolors@1.0.0
promise-inflight@1.0.1
rimraf@2.4.5
rimraf@2.6.3
rimraf@2.7.1
rimraf@3.0.2
sax@1.3.0
semver@5.7.2
semver@6.3.1
semver@7.3.2
semver@7.5.3
semver@7.6.0
setprototypeof@1.2.0

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
11 Packages, Including:
@expo/xcpretty@4.3.1
@react-native/debugger-frontend@0.73.3
charenc@0.0.2
crypt@0.0.2
fbemitter@3.0.0
ieee754@1.2.1
md5@2.2.1
md5@2.3.0
source-map-js@1.0.2
source-map@0.6.1
sprintf-js@1.0.3

BSD 2-Clause "Simplified" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
hold-liable
Must
include-copyright
include-license
10 Packages, Including:
default-gateway@4.2.0
dotenv-expand@10.0.0
dotenv@16.0.3
esprima@4.0.1
esutils@2.0.3
fontfaceobserver@2.3.0
memory-cache@0.2.0
regjsparser@0.9.1
webidl-conversions@3.0.1
webidl-conversions@5.0.0

Apache License 2.0

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
use-patent-claims
place-warranty
Cannot
hold-liable
use-trademark
Must
include-copyright
include-license
state-changes
include-notice
9 Packages, Including:
@ampproject/remapping@2.3.0
chrome-launcher@0.15.2
chromium-edge-launcher@1.0.0
detect-libc@1.0.3
find-yarn-workspace-root@2.0.0
lighthouse-logger@1.4.2
marky@1.2.5
ts-interface-checker@0.1.13
xcode@3.0.1

Mozilla Public License 2.0

Weakly Protective
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
place-warranty
use-patent-claims
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
disclose-source
include-original
9 Packages, Including:
lightningcss-darwin-arm64@1.19.0
lightningcss-darwin-x64@1.19.0
lightningcss-linux-arm-gnueabihf@1.19.0
lightningcss-linux-arm64-gnu@1.19.0
lightningcss-linux-arm64-musl@1.19.0
lightningcss-linux-x64-gnu@1.19.0
lightningcss-linux-x64-musl@1.19.0
lightningcss-win32-x64-msvc@1.19.0
lightningcss@1.19.0

(MIT OR CC0-1.0)

Public Domain
4 Packages, Including:
type-fest@0.16.0
type-fest@0.21.3
type-fest@0.3.1
type-fest@0.7.1

BSD Zero Clause License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
include-copyright
include-license
include-original
Cannot
hold-liable
Must
3 Packages, Including:
jsc-safe-url@0.2.4
password-prompt@1.1.3
tslib@2.6.2

N/A

N/A
2 Packages, Including:
@segment/loosely-validate-event@2.0.0
valid-url@1.0.9

The Unlicense

Public Domain
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
private-use
modify
Cannot
include-copyright
hold-liable
Must
2 Packages, Including:
big-integer@1.6.52
stream-buffers@2.2.0

Blue Oak Model License 1.0.0

Uncategorized
Not OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
Cannot
Must
2 Packages, Including:
jackspeak@2.3.6
path-scurry@1.10.1

Python License 2.0

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
state-changes
1 Packages, Including:
argparse@2.0.1

Creative Commons Attribution 4.0 International

Uncategorized
Not OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
Cannot
Must
1 Packages, Including:
caniuse-lite@1.0.30001596

(BSD-3-Clause OR GPL-2.0)

Permissive
1 Packages, Including:
node-forge@1.3.1

Apache 2.0

Invalid
Not OSI Approved
1 Packages, Including:
qrcode-terminal@0.11.0

(BSD-2-Clause OR MIT OR Apache-2.0)

Expression
1 Packages, Including:
rc@1.2.8
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

2
All Dependencies CSV
β“˜ This is a list of expo-splash-screen 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
@expo/prebuild-config6.3.089.87 kBMIT
prod
2
2
2
expo50.0.11168.52 kBMIT
prod peer
2
4
18
2

Visualizations