Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on Jun 8, 2024 via pnpm

workshopper 2.7.0

A terminal workshop runner framework
Package summary
Share
20
issues
4
critical severity
vulnerability
1
license
3
10
high severity
vulnerability
3
license
4
meta
3
2
moderate severity
vulnerability
2
4
low severity
license
4
6
licenses
29
MIT
3
ISC
3
N/A
5
other licenses
MIT/X11
2
BSD
2
BSD-3-Clause
1
Package created
11 Aug 2013
Version published
9 Jul 2015
Maintainers
4
Total deps
40
Direct deps
10
License
MIT

Issues

20

4 critical severity issues

critical
Recommendation: Upgrade to version 0.2.4 or later
via: optimist@0.6.1
Recommendation: Check the package code and files for license information
via: colors-tmpl@0.1.1
Recommendation: Check the package code and files for license information
via: colors-tmpl@0.1.1
Recommendation: Check the package code and files for license information
via: i18n-core@1.3.3
Collapse
Expand

10 high severity issues

high
Recommendation: Upgrade to version 2.2.1 or later
via: i18n-core@1.3.3
Recommendation: Upgrade to version 4.0.10 or later
via: msee@0.1.2
Recommendation: Upgrade to version 4.0.10 or later
via: msee@0.1.2
Recommendation: Validate that the package complies with your license policy
via: terminal-menu@2.1.1
Recommendation: Validate that the package complies with your license policy
via: optimist@0.6.1
Recommendation: Validate that the package complies with your license policy
via: terminal-menu@2.1.1
Recommendation: Validate that the package complies with your license policy
via: msee@0.1.2
via: colors-tmpl@0.1.1
via: mkdirp@0.3.5
via: i18n-core@1.3.3
Collapse
Expand

2 moderate severity issues

moderate
Recommendation: Upgrade to version 0.6.2 or later
via: msee@0.1.2
Recommendation: Upgrade to version 0.2.1 or later
via: optimist@0.6.1
Collapse
Expand

4 low severity issues

low
Recommendation: Read and validate the license terms
via: terminal-menu@2.1.1
Recommendation: Read and validate the license terms
via: optimist@0.6.1
Recommendation: Read and validate the license terms
via: terminal-menu@2.1.1
Recommendation: Read and validate the license terms
via: msee@0.1.2
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
29 Packages, Including:
ansi-styles@1.0.0
ansicolors@0.2.1
cardinal@0.5.0
chalk@0.4.0
core-util-is@1.0.3
has-color@0.1.7
isarray@0.0.1
map-async@0.1.1
marked@0.3.19
minimist@0.0.10
mkdirp@0.3.5
msee@0.1.2
nopt@2.1.2
object-keys@0.4.0
readable-stream@1.0.34
readable-stream@1.1.14
redeyed@0.5.0
resumer@0.0.0
string_decoder@0.10.31
strip-ansi@0.1.1
terminal-menu@2.1.1
through2@0.6.5
through@2.3.8
visualwidth@0.0.1
wordwrap@0.0.3
workshopper@2.7.0
xtend@2.1.2
xtend@3.0.0
xtend@4.0.2

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
3 Packages, Including:
abbrev@1.1.1
i18n-core@1.3.3
inherits@2.0.4

N/A

N/A
3 Packages, Including:
colors-tmpl@0.1.1
colors@0.6.2
mustache@0.8.2

MIT/X11

Invalid
Not OSI Approved
2 Packages, Including:
charm@0.1.2
optimist@0.6.1

BSD

Invalid
Not OSI Approved
2 Packages, Including:
duplexer2@0.0.2
esprima-fb@12001.1.0-dev-harmony-fb

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
1 Packages, Including:
sprintf@0.1.5
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

10
All Dependencies CSV
β“˜ This is a list of workshopper 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
chalk0.4.02.47 kBMIT
prod
colors-tmpl0.1.13.71 kBUNKNOWN
prod
2
1
i18n-core1.3.36.19 kBISC
prod
1
2
map-async0.1.12.35 kBMIT
prod
mkdirp0.3.54.06 kBMIT
prod
1
msee0.1.23.48 kBMIT
prod
3
1
1
optimist0.6.112.06 kBMIT/X11
prod
1
1
1
1
terminal-menu2.1.14.4 kBMIT
prod
2
2
visualwidth0.0.118.95 kBMIT
prod
xtend3.0.02.39 kBMIT
prod

Visualizations