Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on Feb 10, 2024 via pnpm

near-api-js 3.0.2

JavaScript library to interact with NEAR Protocol via RPC API
Package summary
Share
13
issues
1
high severity
meta
1
12
moderate severity
meta
12
5
licenses
25
MIT
13
ISC
2
(MIT AND Apache-2.0)
3
other licenses
BSD-2-Clause
2
Apache-2.0
1
Package created
8 Apr 2020
Version published
11 Jan 2024
Maintainers
7
Total deps
43
Direct deps
20
License
(MIT AND Apache-2.0)

Issues

13

1 high severity issue

high
via: @near-js/accounts@1.0.2 & others
Collapse
Expand

12 moderate severity issues

moderate
via: @near-js/accounts@1.0.2 & others
via: @near-js/accounts@1.0.2 & others
via: @near-js/keystores-browser@0.0.8
via: @near-js/keystores-node@0.0.8
via: @near-js/accounts@1.0.2 & others
via: @near-js/accounts@1.0.2 & others
via: @near-js/accounts@1.0.2 & others
via: @near-js/accounts@1.0.2 & others
via: @near-js/accounts@1.0.2 & others
via: @near-js/accounts@1.0.2 & others
via: @near-js/wallet-account@1.0.2
via: @near-js/accounts@1.0.2 & others
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
25 Packages, Including:
@noble/curves@1.2.0
@noble/hashes@1.3.2
@noble/hashes@1.3.3
@types/json-schema@7.0.15
ajv-formats@2.1.1
ajv@8.11.2
base-x@2.0.6
bn.js@5.2.1
bs58@4.0.0
depd@1.1.2
depd@2.0.0
fast-deep-equal@3.1.3
http-errors@1.7.2
json-schema-traverse@1.0.0
lru_map@0.4.1
mustache@4.0.0
node-fetch@2.6.7
punycode@2.3.1
randombytes@2.1.0
require-from-string@2.0.2
safe-buffer@5.2.1
statuses@1.5.0
toidentifier@1.0.0
tr46@0.0.3
whatwg-url@5.0.0

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
13 Packages, Including:
@near-js/accounts@1.0.2
@near-js/crypto@1.2.0
@near-js/keystores-browser@0.0.8
@near-js/keystores-node@0.0.8
@near-js/keystores@0.0.8
@near-js/providers@0.0.10
@near-js/signers@0.1.0
@near-js/transactions@1.1.0
@near-js/types@0.0.4
@near-js/utils@0.0.5
@near-js/wallet-account@1.0.2
inherits@2.0.3
setprototypeof@1.1.1

(MIT AND Apache-2.0)

Permissive
2 Packages, Including:
near-abi@0.1.1
near-api-js@3.0.2

BSD 2-Clause "Simplified" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
hold-liable
Must
include-copyright
include-license
2 Packages, Including:
uri-js@4.4.1
webidl-conversions@3.0.1

Apache License 2.0

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
use-patent-claims
place-warranty
Cannot
hold-liable
use-trademark
Must
include-copyright
include-license
state-changes
include-notice
1 Packages, Including:
borsh@1.0.0
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

20
All Dependencies CSV
β“˜ This is a list of near-api-js 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
@near-js/accounts1.0.230.5 kBISC
prod
1
9
@near-js/crypto1.2.04.67 kBISC
prod
1
3
@near-js/keystores-browser0.0.83.6 kBISC
prod
1
5
@near-js/keystores-node0.0.84.22 kBISC
prod
1
5
@near-js/keystores0.0.84.67 kBISC
prod
1
4
@near-js/providers0.0.1010.26 kBISC
prod
1
7
@near-js/signers0.1.03.63 kBISC
prod
1
5
@near-js/transactions1.1.010.9 kBISC
prod
1
6
@near-js/types0.0.45.22 kBISC
prod
1
@near-js/utils0.0.516.04 kBISC
prod
1
2
@near-js/wallet-account1.0.29.21 kBISC
prod
1
10
@noble/curves1.2.0262.8 kBMIT
prod
ajv-formats2.1.114.5 kBMIT
prod
ajv8.11.2214.52 kBMIT
prod peer
bn.js5.2.121.32 kBMIT
prod
borsh1.0.017.52 kBApache-2.0
prod
depd2.0.08.18 kBMIT
prod
http-errors1.7.25.76 kBMIT
prod
near-abi0.1.12.5 kB(MIT AND Apache-2.0)
prod
1
node-fetch2.6.740.77 kBMIT
prod optional

Visualizations