Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Generated on Jul 10, 2024 via pnpm

express-restify-mongoose 8.0.0

Easily create a flexible REST interface for mongoose models
Package summary
Share
0
issues
6
licenses
75
Apache-2.0
32
MIT
2
BSD-3-Clause
3
other licenses
0BSD
1
(MIT OR CC0-1.0)
1
BSD-2-Clause
1
Package created
24 Mar 2013
Version published
2 Oct 2023
Maintainers
2
Total deps
112
Direct deps
5
License
MIT

Issues

0
This package has no issues

Licenses

Apache License 2.0

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
use-patent-claims
place-warranty
Cannot
hold-liable
use-trademark
Must
include-copyright
include-license
state-changes
include-notice
75 Packages, Including:
@aws-crypto/sha256-browser@5.2.0
@aws-crypto/sha256-js@5.2.0
@aws-crypto/supports-web-crypto@5.2.0
@aws-crypto/util@5.2.0
@aws-sdk/client-cognito-identity@3.614.0
@aws-sdk/client-sso-oidc@3.614.0
@aws-sdk/client-sso@3.614.0
@aws-sdk/client-sts@3.614.0
@aws-sdk/core@3.614.0
@aws-sdk/credential-provider-cognito-identity@3.614.0
@aws-sdk/credential-provider-env@3.609.0
@aws-sdk/credential-provider-http@3.614.0
@aws-sdk/credential-provider-ini@3.614.0
@aws-sdk/credential-provider-node@3.614.0
@aws-sdk/credential-provider-process@3.614.0
@aws-sdk/credential-provider-sso@3.614.0
@aws-sdk/credential-provider-web-identity@3.609.0
@aws-sdk/credential-providers@3.614.0
@aws-sdk/middleware-host-header@3.609.0
@aws-sdk/middleware-logger@3.609.0
@aws-sdk/middleware-recursion-detection@3.609.0
@aws-sdk/middleware-user-agent@3.614.0
@aws-sdk/region-config-resolver@3.614.0
@aws-sdk/token-providers@3.614.0
@aws-sdk/types@3.609.0
@aws-sdk/util-endpoints@3.614.0
@aws-sdk/util-locate-window@3.568.0
@aws-sdk/util-user-agent-browser@3.609.0
@aws-sdk/util-user-agent-node@3.614.0
@smithy/abort-controller@3.1.1
@smithy/config-resolver@3.0.5
@smithy/core@2.2.6
@smithy/credential-provider-imds@3.1.4
@smithy/fetch-http-handler@3.2.1
@smithy/hash-node@3.0.3
@smithy/invalid-dependency@3.0.3
@smithy/is-array-buffer@2.2.0
@smithy/is-array-buffer@3.0.0
@smithy/middleware-content-length@3.0.3
@smithy/middleware-endpoint@3.0.5
@smithy/middleware-retry@3.0.9
@smithy/middleware-serde@3.0.3
@smithy/middleware-stack@3.0.3
@smithy/node-config-provider@3.1.4
@smithy/node-http-handler@3.1.2
@smithy/property-provider@3.1.3
@smithy/protocol-http@4.0.3
@smithy/querystring-builder@3.0.3
@smithy/querystring-parser@3.0.3
@smithy/service-error-classification@3.0.3

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
32 Packages, Including:
@mongodb-js/saslprep@1.1.7
@types/node@20.14.10
@types/webidl-conversions@7.0.3
@types/whatwg-url@8.2.2
base64-js@1.5.1
bowser@2.11.0
buffer@5.7.1
debug@4.3.5
dot-prop@7.2.0
express-restify-mongoose@8.0.0
fast-xml-parser@4.2.5
ip-address@9.0.5
jsbn@1.1.0
lodash.isplainobject@4.0.6
memory-pager@1.5.0
mongoose@6.13.0
mpath@0.9.0
mquery@4.0.3
ms@2.1.2
ms@2.1.3
punycode@2.3.1
serialize-error@11.0.3
sift@16.0.1
smart-buffer@4.2.0
socks@2.8.3
sparse-bitfield@3.0.3
strnum@1.0.5
tr46@3.0.0
undici-types@5.26.5
uuid@9.0.1
whatwg-url@11.0.0
zod@3.23.8

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
2 Packages, Including:
ieee754@1.2.1
sprintf-js@1.1.3

BSD Zero Clause License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
include-copyright
include-license
include-original
Cannot
hold-liable
Must
1 Packages, Including:
tslib@2.6.3

(MIT OR CC0-1.0)

Public Domain
1 Packages, Including:
type-fest@2.19.0

BSD 2-Clause "Simplified" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
hold-liable
Must
include-copyright
include-license
1 Packages, Including:
webidl-conversions@7.0.0
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

5
All Dependencies CSV
β“˜ This is a list of express-restify-mongoose 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
dot-prop7.2.04.49 kBMIT
prod
lodash.isplainobject4.0.62.96 kBMIT
prod
mongoose6.13.02.2 MBMIT
prod
serialize-error11.0.35.08 kBMIT
prod
zod3.23.8651.16 kBMIT
prod

Visualizations