Home
Docs
GitHub
Pricing
Blog
Log In

Run Sandworm Audit for your App

Get started
Hold on, we're currently generating a fresh version of this report
Generated on May 9, 2024 via pnpm

babel-plugin-css-modules-transform 1.6.2

Transform required css modules so one can use generated class names.
Package summary
Share
6
issues
1
critical severity
vulnerability
1
2
high severity
vulnerability
1
license
1
2
moderate severity
vulnerability
2
1
low severity
license
1
4
licenses
27
MIT
5
ISC
1
BSD
1
BSD-3-Clause
Package created
17 Nov 2015
Version published
25 Nov 2018
Maintainers
1
Total deps
34
Direct deps
2
License
MIT

Issues

6

1 critical severity issue

critical
Recommendation: Upgrade to version 1.4.1 or later
via: css-modules-require-hook@4.2.3
Collapse
Expand

2 high severity issues

high
Recommendation: Upgrade to version 1.0.2 or later
via: css-modules-require-hook@4.2.3
Recommendation: Validate that the package complies with your license policy
via: css-modules-require-hook@4.2.3
Collapse
Expand

2 moderate severity issues

moderate
Recommendation: Upgrade to version 7.0.36 or later
via: css-modules-require-hook@4.2.3
Recommendation: Upgrade to version 8.4.31 or later
via: css-modules-require-hook@4.2.3
Collapse
Expand

1 low severity issue

low
Recommendation: Read and validate the license terms
via: css-modules-require-hook@4.2.3
Collapse
Expand

Licenses

MIT License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
sublicense
private-use
Cannot
hold-liable
Must
include-copyright
include-license
27 Packages, Including:
ansi-styles@3.2.1
babel-plugin-css-modules-transform@1.6.2
big.js@3.2.0
chalk@2.4.2
color-convert@1.9.3
color-name@1.1.3
css-modules-require-hook@4.2.3
css-selector-tokenizer@0.7.3
cssesc@3.0.0
debug@2.6.9
emojis-list@2.1.0
escape-string-regexp@1.0.5
fastparse@1.1.2
generic-names@1.0.3
has-flag@3.0.0
json5@0.5.1
loader-utils@0.2.17
lodash@4.17.21
minimist@1.2.8
mkdirp@0.5.6
ms@2.0.0
object-assign@4.1.1
postcss-modules-local-by-default@1.2.0
postcss-modules-resolve-imports@1.3.0
postcss@6.0.23
seekout@1.0.2
supports-color@5.5.0

ISC License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
Cannot
hold-liable
Must
include-copyright
include-license
5 Packages, Including:
icss-replace-symbols@1.1.0
icss-utils@3.0.1
postcss-modules-extract-imports@1.2.1
postcss-modules-scope@1.1.0
postcss-modules-values@1.3.0

BSD

Invalid
Not OSI Approved
1 Packages, Including:
glob-to-regexp@0.3.0

BSD 3-Clause "New" or "Revised" License

Permissive
OSI Approved
This is a human-readable summary of (and not a substitute for) the license. Disclaimer.
Can
commercial-use
modify
distribute
place-warranty
Cannot
use-trademark
hold-liable
Must
include-copyright
include-license
1 Packages, Including:
source-map@0.6.1
Disclaimer

This deed highlights only some of the key features and terms of the actual license. It is not a license and has no legal value. You should carefully review all of the terms and conditions of the actual license before using the licensed material.

Sandworm is not a law firm and does not provide legal services. Distributing, displaying, or linking to this deed or the license that it summarizes does not create a lawyer-client or any other relationship.

Direct Dependencies

2
All Dependencies CSV
β“˜ This is a list of babel-plugin-css-modules-transform 's direct dependencies. Data on all dependencies, including transitive ones, is available via CSV download.
NameVersionSizeLicenseTypeVulnerabilities
css-modules-require-hook4.2.348.43 kBMIT
prod
1
2
2
1
mkdirp0.5.62.95 kBMIT
prod

Visualizations